Problem with TangoTest device server

Pascal
Hi
Seeing your picture I confirm that your server TangoTest/test is NOT registered (not running) on your machine named ZPY-PC.
Why ? I don't know.
A problem at server startup ?

Normally, when a server start it register itself in database as running on the host.
The Starter/Astor tool will get server list using this feature.
But in your case, we cannot see TangoTest/Test on host ZPY-PC.

maybe i think is there any problem at my tangotest server starup?
because i startup it from astor, no pop-up windows to tell me the Server is OK….
when i startup it again,it will tell me the server is running.but the answer of DbGetHostServerList is the same as before.
i have try to registered it from Jive but nothing changed
Edited 8 months ago
peipei
i have copy the tangotest.exe to C:\DeviceServers\bin
TANGO_HOST=ZPY-PC:10000
other config as pictures show
am i right?
Seems OK to me for the Astor config step but I'm not TANGO under windows expert.

However, I see in your first snapshots a 8XNUX… host running a DB but I see here you set TANGO_HOST to ZPY-PC:10000.
Perhaps I missed something but do you you have two computers (8XNUX… and ZPY-PC, one server and one client, and then is TANGO_HOST defined to the same value on both?) or just one?
- Philippe
philippeg
peipei
i have copy the tangotest.exe to C:\DeviceServers\bin
TANGO_HOST=ZPY-PC:10000
other config as pictures show
am i right?
Seems OK to me for the Astor config step but I'm not TANGO under windows expert.

However, I see in your first snapshots a 8XNUX… host running a DB but I see here you set TANGO_HOST to ZPY-PC:10000.
Perhaps I missed something but do you you have two computers (8XNUX… and ZPY-PC, one server and one client, and then is TANGO_HOST defined to the same value on both?) or just one?
YES I have two computers.
TANGO_HOST=ZPY-PC:10000, the ZPY-PC is the host computer and running MYSQL
8XNUX… is the client and TANGO_HOST=ZPY-PC:10000 too,so astor at 8XNUX… can link to database directly.
Did you start Astor and Starter with TANGO_HOST=ZPY-PC:10000 ?
Because on your screen shot we saw another TANGO_HOST.
Pascal
Did you start Astor and Starter with TANGO_HOST=ZPY-PC:10000 ?
Because on your screen shot we saw another TANGO_HOST.
this picture was snap at client computer.and i was test the tango system..
i do this test with TANGO_HOST=localhost:10000
when i finish the test, i change the TANGO_HOST as ZPY-PC:10000 where tho database running
peipei
this picture was snap at client computer.and i was test the tango system..
i do this test with TANGO_HOST=localhost:10000
when i finish the test, i change the TANGO_HOST as ZPY-PC:10000 where tho database running
In your case, TANGO_HOST should always be the same, it should be equal to the server with database.
TANGO_HOST is the way for each client to understand where to connect to the TANGO central database.
- Philippe
philippeg
peipei
this picture was snap at client computer.and i was test the tango system..
i do this test with TANGO_HOST=localhost:10000
when i finish the test, i change the TANGO_HOST as ZPY-PC:10000 where tho database running
In your case, TANGO_HOST should always be the same, it should be equal to the server with database.
TANGO_HOST is the way for each client to understand where to connect to the TANGO central database.
yes,they are the same now~
thank you for your advicesmile
Edited 8 months ago
peipei
yes,they are the same now~
thank you for your advicesmile
Does it work now? You will need to start again your device servers.
- Philippe
philippeg
peipei
yes,they are the same now~
thank you for your advicesmile
Does it work now? You will need to start again your device servers.
:'(
problem dont fix~~

the TANGO_HOST was the same for 2 weeks….

when i finish the install of tango system into client computer , i change the TANGO_HOST of client computer from localhost:10000 to ZPY-PC:10000. These steps were doing at 2 weeks ago..
Hi Peipei,

Did you try to do the following?:
  • Kill your TangoTest instance (using Windows Task Manager or sending the kill command to dserver/TangoTest/test device) on ZPY-PC
  • Verify that your device server is marked as not exported/not running in jive
  • Try to start the TangoTest/test device server from astor on the same host

Please do not hesitate to ask questions if some steps I described above are not clear.

If this doesn't work, I would try to ensure TangoTest/test is not running on your computer and try to start it up from a console/terminal, using -v4 or -v5 option to see if there are some eventual error messages during the startup.

TangoTest test -v4

I hope we will manage to understand the strange behaviour you're observing.

Do you see the same problem if you create another instance of TangoTest (for example: TangoTest/test2)?
Rosenberg's Law: Software is easy to make, except when you want it to do something new.
Corollary: The only software that's worth making is software that does something new.
 
Register or login to create to post a reply.