Problem with TangoTest device server

Reynald
Hi,

In theory, you should be able to see your device server in the Astor Control Window of your host under the section "Not Controlled" but it seems there is no such section in your case… Not yet clear why… But this is maybe because of the fact that the host name is all uppercase and your starter instance name is lowercase? or maybe because you are on Windows…? The Starter/astor expert will hopefully get a better idea when he will be back from holidays.

What I would do if I were you would be:
  1. to kill the TangoTest device server, using whatever solution you prefer (Task manager or kill command from TangoTest admin device dserver/tangotest/test)
  2. to start your device server using astor as you already tried to do. But this needs to be done while the device server is not currently running so the first step is important.

Then you should be able to see TangoTest/test in astor. If not, I would then try to rename the starter instance and put it all in uppercase (Starter/8XNU…T6A) since your host seems to be defined in uppercase and restart the Starter.

i will try to rename the starter with all in uppercase .thank you
Hi Peipei
Could you try to test your database device server as shown on picture.
If everything is fine, you will see your servers registered for specified host in device response.
The argument is your host name.
Pascal
Edited 3 months ago
Pascal
Hi Peipei
Could you try to test your database device server as shown on picture.
If everything is fine, you will see your servers registered for specified host in device response.
The argument is your host name.
Pascal
I think the test is ok.as the picture show…
but it dont display at astor's control panel
peipei
I add the host and DS all followed the steps you mentioned above.
Could you show a snapshot of the window with the configuration to check the syntax is correct?
- Philippe
Hi
Your picture has no link to mine.
My request was to test the Database device, not yours.
Please could you do the test as specified and send me the result.
Pascal
Hi Peipei
Could you try to test your database device server as shown on picture.
If everything is fine, you will see your servers registered for specified host in device response.
The argument is your host name.
Pascal
I have update the picture
philippeg
peipei
I add the host and DS all followed the steps you mentioned above.
Could you show a snapshot of the window with the configuration to check the syntax is correct?
sorry i dont understand what configuration you want..
could you tell me more details?smile
thank you

peipei
philippeg
peipei
I add the host and DS all followed the steps you mentioned above.
Could you show a snapshot of the window with the configuration to check the syntax is correct?
sorry i dont understand what configuration you want..
could you tell me more details?smile
thank you

I mean the configuration you entered at the step described in https://tango-controls.readthedocs.io/en/latest/tools-and-extensions/astor/add_host.html
- Philippe
Hi
Seeing your picture I confirm that your server TangoTest/test is NOT registered (not running) on your machine named ZPY-PC.
Why ? I don't know.
A problem at server startup ?

Normally, when a server start it register itself in database as running on the host.
The Starter/Astor tool will get server list using this feature.
But in your case, we cannot see TangoTest/Test on host ZPY-PC.
philippeg
peipei
philippeg
peipei
I add the host and DS all followed the steps you mentioned above.
Could you show a snapshot of the window with the configuration to check the syntax is correct?
sorry i dont understand what configuration you want..
could you tell me more details?smile
thank you

I mean the configuration you entered at the step described in https://tango-controls.readthedocs.io/en/latest/tools-and-extensions/astor/add_host.html

i have copy the tangotest.exe to C:\DeviceServers\bin
TANGO_HOST=ZPY-PC:10000
other config as pictures show
am i right?
 
Register or login to create to post a reply.