Can't start tangotest

Hello/ i have problems with tangtest starting. I've already red the topic
And what I have: I have TANGO_HOST variable as MyComputerName:10000
I started start-db.bat:
D:\tango-root\tango\bin>start-db.bat -v4
main(): arrived
main(): export DataBase as named servant (name=database)
Ready to accept request

Then I opened new cmd window, started tangotest and z have the error:
D:\tango-root\tango\bin>start-tangotest.bat test -v4 Can't build connection to TANGO database server, exiting
Then I started start-jive.bat and have the error (in the picture)
Can you give me some advises to start tangotest?
My next task is to try make pseudo server and pseudo client on my machine with PyTango, so I should be sure that tango is working.

Obviously there is a problem with the declaration of your TANGO_HOST for your jive startup and perhaps also when starting TangoTest.
in the error message of jive, you see that jive try to connect to
Your TANGO_HOST is WIN-8I0FBLHT50D:10000. Are you sure your hostname is recognized as WIN-8I0FBLHT50D?
try execute ping WIN-8I0FBLHT50D to verify it points to your machine.
you can also try "nslookup WIN-8I0FBLHT50D" to verify the ip address of this name corresponds to the ip address of your computer.
your TANGO_HOST variable should be the same when starting database server, jive and tangotest.
Thank you, Jean-Michel. I tried to ping WIN-8I0FBLHT50D.
as far as I understood, it is OK hostname. You can see the result in the picture
If I understand well your screenshot in russian, you are configured in network IPV6. Unfortunately this may be the cause of the problem. Tango had not been adapted to IPV6. Can you try using PI V4?
I executed "ping hostname -4" and translated the answer for you:
C:\Users\User>ping WIN-8I0FBLHT50D -4 Packeges exchange with WIN-8I0FBLHT50D [] with 32 bites of data:
Answer from num of bites=32 время<1мс TTL=128 Answer from num of bites=32 время<1мс TTL=128 Answer from num of bites=32 время<1мс TTL=128 Answer from num of bites=32 время<1мс TTL=128 Statistics Ping for Packeges: sent = 4, recieved = 4, lost= 0 (0% losts) approximate time of reception-transfer in ms: Minimal = 0мсек, Max = 0 мсек, Average = 0 мсек

I don't know, what version of IP my computer uses when I start database. May be expression "-v4" controlls IP version ? But in this case I don't know what my problem is..
Perhaps you have a problem with the name server. Let's try another command to verify the correct ip address:
in the cmd window type "hostname"
It should give you the name of your machine.
Then type nslookup <name> (where <name> is the answer of the "hostname" command).
see example below

Try to set the TANGO_HOST using directly the IP address given by nslookup.
Use the environment variable TANGO_HOST=
Start the database
then start jive with the same TANGO_HOST. You should be able to browse the database.
Edited 2 years ago
Hi Anna,

IPv6 is the new (10 years old) internet protocol:

As you can see from Wikipedia the addresses are much longer in IPv6 (see e.g. 2001:0db8:85a3:0000:0000:8a2e:0370:7334 compared to an IPv4 (the old and still largely used internet protocol)address which has only 4 bytes e.g.

Tango supports only IPv4 (even if the underlying protocols omniORB and ZMQ support IPv6). I don't know if anyone uses Tango with IPv6 - maybe someone has but I am not aware of it.

What Jean-Michel is suggesting is to use IPv4 addresses on your Windows laptop. This help page from Microsoft tells you how to switch on IPv4 under Windows:

Hope that makes it clearer.


Hi again,

I have enabled IPv6 on my Windows laptop just to see if I can reproduce your problem. I have IPv4 and IPv6 enabled but am using IPv4 as the network protocol because our site uses IPv4. Even if IPv6 enabled on my laptop I can start the database server and run jive to browse the database.

What does the nslookup command return for your laptop? For example on my laptop it returns:

PS C:\Program Files\tango\bin> nslookup lapgotz


As you can see the IP address is IPv4. In jive I see it with the IPv4 address:

- Device Info —————————————-

Device: sys/database/2
type_id: IDL:Tango/Device_5:1.0
iiop_version: 1.2
host: (
port: 10000
Server: DataBaseds/2
Server PID: 10008
Exported: true
last_exported: 10th July 2018 at 10:28:18
last_unexported: 10th July 2018 at 10:27:21

Thank you for your answers. First of all:
D:\tango-root\tango\bin>nslookup WIN-8I0FBLHT50D
Server: UnKnown
Address: *** UnKnown doesn't found WIN-8I0FBLHT50D: Non-existent domain

In IP settings I see next information:
SSID: dlink
Protocol: 802.11n
Security type: WPA2-Personal
Net diapason: 2,4 ГГц
Net chanal: 4
Manufacturer: Qualcomm Atheros Communications Inc.
Description: Qualcomm Atheros AR9485WB-EG Wireless Network Adapter
Driver version:
(MAC): ‎18-CF-5E-C1-AC-45

I haven't "Edit" like in manual, but my laptop uses IPv4, am I right?

Also, I already tried to set veriable as TANGO_HOST= (befor I wrote in this forum) but it didn't help me..


Do you have others networks activated ?
Can you do a ipconfig /all ?
Register or login to create to post a reply.