Tango starter Host address seen as localhost and then unreachable from other computer


Since the release of Tango 9.4.1 Windows installer, I upgraded one of our existing tango database whioch went fine.

The only issue I currently have is that the starter, which works perfectly from the server it is running on and starts all our devices, is seen as not running from other computers on the network (using astor or jive).

I've noticed that the current host for the starter in jive is displayed as (localhost) instead of the actual name of the server and/or IP address.

Started devices appear to be fine and can be reached and operated without issue and their host is set as "COMPUTER_NAME (COMPUTER IP)", as expected.

Does someone knows why this behaviour is happening?

I shall add that it worked perfectly while the database was in older version 8.2.2 and that it still works if I revert to 8.2.2.
Guillaume DI FRANCO
Thales - Software Engineer Manager
Hi Hiro,
Our windows expert is going to have a look at this issue in the upcoming days. Stay tuned.
Meanwhile, could you please give 9.4.2-rc2 a try to see if the behavior is the same?
Edited 3 months ago
Hi Hiro,

I have unsuccessfully tried to reproduce this on my system with the Tango 9.4.1 on Windows using the installer. I am running TangoDB and Starter on a Windows VM and when I connect with Jive (from either my Linux host or the Windows VM) I see the correct host information for the Starter device.

I have not upgraded my database schema from version 8, but created it from scratch. Perhaps this is the difference.

Could you check if the Starter is exported in the database? You can check this by launching a mysql client and connecting to your database and running the following:

> USE tango;
> SELECT name, host, exported FROM device WHERE name REGEXP 'starter';

I assume that this will say that the device is not exported as that is what Jive reports, but this should help narrow down the problem.
Register or login to create to post a reply.