Dserver logging default behaviour


i have a question regarding logging in Tango. One of its type is dserver-level logging which is AFAIK at the warning level by default. Is there any way of configuring the default behaviour? If i execute "StopLogging" command on dserver device it indeed stops logging but as soon as I restart the device, the login returns to the warning level. It is a problem for us because one of our devices keeps logging a lot (log files up to 10GB from dserver) but with no need to do so.

Thanks for any help!

Hi Michal

There are device properties to control the Tango logging. You can try adding the logging_level device property set to "ERROR", or some other level.



It could also be that you are passing a log level on the command line. E.g,. adding the "-v1" option would give the least logs, and "-v5" the most. Note that adding this option will cause logs be output to the console (i.e., it adds the logging target "console").

Register or login to create to post a reply.