Access to the tangobox from outside

Hello,

I have a windows machine on which I installed Tango and a tangobox 9.2 (VirtualBox)
I would like to use Tango clients on my machine with the tangobox server.
I managed to configure so that the machine communicates with the tangobox (ping, astor ..).
The problem is that I can't access the Starter and Device Servers which are in the docker containers :(
(Screenshot attached).

I also tried with another linux machine, made a local network with the container IPs (172.xxx), modified the /etc/hosts file in a container … maybe an authorization problem …
I am not an expert in docker …

Is it possible ? If so, does anyone have an idea? Thank you
I think you can refer to this section of the documentation to start and stop the docker containers on the TangoBox:
https://tango-controls.readthedocs.io/en/latest/installation/vm/tangobox.html#container-switch-on-off

The docker containers might not be started?

docker start tangobox-com should do the trick to start tangobox-com docker container.
Rosenberg's Law: Software is easy to make, except when you want it to do something new.
Corollary: The only software that's worth making is software that does something new.
Hello,

the docker containers are all started in the tangobox.

It is when I am on an external machine that I see them not started, with for example Astor: the leds are red (starter and DS not accessible)

Thank you.
Hi @JCM,

Sorry for the late answer. You need to enable forwarding on the Tangobox:
sudo sysctl net.ipv4.conf.all.forwarding=1
sudo iptables -P FORWARD ACCEPT

This should be added to some startup script as it does not stay between restarts.

Remember to use a bridged network on the Virtualbox network settings. See the attached screenshots.


Then the setup needs a proper network configuration with a proper route added to the 2nd machine.

I have tested this with the following IPs provided manually:
TangoBox:
IP: 172.19.0.1/16, GW: 172.19.0.1

2nd machine:
IP: 172.19.0.2/16, GW: 172.19.0.1
Manually added route: 172.18.0.1/16 via 172.18.0.1



All the best,
Piotr
Edited 2 weeks ago
Great, thank you Piotr.
You gave me the solution smile
Cheers.
 
Register or login to create to post a reply.