Tango 9 Windows demo installation problem

I am the completely new to the Tango Controls.
I am installing Tango 9 on Windows 10, MySQL 8.0.

I do follow the procedure as per https://tango-controls.readthedocs.io/en/latest/installation/tango-on-windows.html

When I try to install TangoTest device server using Astor tool, I get the following error:

"Failed to query TANGO database (error=Field 'date' doesn't have a default value)
.The query was: INSERT INTO property_device_hist SET device='tango/admin/test',id='3',name='StartDsPath',count='1',value='c:\\tango\\bin'"

Hi,

This is probably due to MySQL settings: STRICT_TRANS_TABLES SQL mode. I don't know where is my.ini (or my.cnf) for your installation, but you need to find it and remove STRICT_TRANS_TABLES from line starting with
sql_mode=
You may refer to the following pages:
  • https://stackoverflow.com/questions/15438840/mysql-error-1364-field-doesnt-have-a-default-values and
  • https://dev.mysql.com/doc/refman/8.0/en/windows-troubleshooting.html

  • Best regards,
    Piotr
    Thank you so much. That worked.
    Hello,
    I try to install tango with the same procedure on windows 7, mysql 5.5 i have many problems like when
    I have defined the environment variables as well as the username and the password but I always have an error (attached) when I run "" start-db.bat"".

    So, I tried this other stuff.
    for 3.5 Start the test device server tangotest: When I type start-tangotest.bat 1 -v4, I have this :
    c:\tango-root\bin>start-tangotest.bat 1 -v4
    Can't build connection to TANGO database server, exiting

    before that for ""create_db.bat"" I encountered an error (attached).
    so I launched directly the script sql and I run it, i don't know if it's right.
    thank you,
    Hi, it looks like you forget to create a database user. Try to follow the text instrution:
    https://tango-controls.readthedocs.io/en/dev/installation/tango-on-windows.html#tango-host-role

    And look at this part:

    Invoke command: %TANGO_ROOT%\bin\dbconfig.exe.

    Note

    This lets you setup two environment variables MYSQL_USER and MYSQL_PASSWORD used to access the MySQL server. You may use root credentials provided upon MySQL installation if it is your development workstation. For production environment it is suggested to create an additional user with DB Admin privileges. On Windows you may use MySQL Installer from Start menu and select the option Reconfigure for MySQL Server. Please refer to: http://dev.mysql.com/doc/refman/5.7/en/adding-users.html

    Good luck!
    Piotr
    Edited 6 months ago
    I'm trying to install tango 9.2.2 on Windows7.
    I installed MySQL server 8.0 community.
    When I runing create_db.bat, I get following error:
    ERROR 1071 (42000) at line 257 in file: 'create_db_tables.sql': Specified key was too long; max key length is 1000 bytes
    Edited 4 months ago
    Hi,

    It looks like a workaround can be to edit %TANGO_ROOT%\share\tango\db\create_db.sql and to replace the following line

    CREATE DATABASE tango;

    with
    CREATE DATABASE tango DEFAULT CHARACTER SET utf8 DEFAULT COLLATE utf8_general_ci;


    Workaround found on https://stackoverflow.com/questions/20014106/how-to-create-this-table-1071-specified-key-was-too-long-max-key-length-is/42497309

    An older version of MySQL would also probably work smile
    Rosenberg's Law: Software is easy to make, except when you want it to do something new.
    Corollary: The only software that's worth making is software that does something new.
    Edited 4 months ago
    So, I installed mysql-5.1.73-winx64 but there was another error
    Incorrect table definition; there can be only one TIMESTAMP column with CURRENT_TIMESTAMP in DEFAULT or ON UPDATE clause


    And I edited create_db_tables.sql:
    changed CURRENT_TIMESTAMP on lines 11 and 25
    to '2000-01-01 00:00:00' (as in latest github source).

    It worked.smile
    Edited 4 months ago
     
    Register or login to create to post a reply.