PyTango installation failed

I didn't reach to install my favorite PyTango smile on ubuntu.
The documentation said :
sudo apt-get install python-pytango ->don't work, no package python-pytango

on pip :
pip3 install PyTango -> don't work
failed building wheel for PyTango

I installed numpy & boost
sudo apt install libboost-all-dev
failed again

tried to install from the sources
and now couldn't find tango.h
I don't understand, it was so simple before…
Hi Olivier,

doesn't sound right! Which Ubuntu are you trying it on?

Hi Andy,
ubuntu 20.04 LTS
I can try on the previous version.
It seems this is a problem with PyTango & Ubuntu 20.
I reached to install pytango on Ubuntu 18 simply with :
apt install python-pytango #no problem

I also tried the python 3 version:
apt install python3-pytango #no problem

go back to Ubuntu 20 : python3-pytango package exist but version is not good.
Hi Olivier,
Just checked this, and it seems that the package is now called python3-tango.
I was able to install PyTango on a fresh Ubuntu 20.04 installation with
sudo apt install python3-tango

This installs PyTango 9.3.0.
I don't know however why the package name was changed.

If you want a newer version you can install it from pip, you need libboost-python-dev (for boost-python binding) and libtango-dev (for tango.h and Tango itself).
sudo apt install libboost-python-dev libtango-dev
sudo pip3 install pytango

This works for PyTango 9.3.2.

I didn't try with the sources, but I suppose the requirements are the same as for pip installation.

For python2, it seems there is no pytango package and not even pip2 package in the Ubuntu repositories.

Hope this helps!

On ubuntu 20.04 we have cppTango 9.2.5 and python3-tango 9.3.0. To my undestanding the packaging is broken because 9.3 may not to work with 9.2.

One can try to fix it by installing cpptango 9.3 from conda but it is not so convinient.

Hi Jan,
Indeed the cppTango version is 9.2.5 and PyTango is 9.3.0 or 9.3.2 (from pip), but for a simple test (just messing around with TangoTest device) I didn't notice any problems.
Register or login to create to post a reply.