Error while installing TANGO 9.2.5a on Ubuntu 16.04 LTS

Hi All,
We tried to install TANGO 9.2.5a on UBUNTU 16.04 LTS.
We are getting following exception.

make[2]: Entering directory '/opt/software/tango-9.2.5a/cppserver/tangotest'
make[3]: Entering directory '/opt/software/tango-9.2.5a/cppserver/tangotest'
/bin/mkdir -p '/usr/local/bin'
/bin/bash ../../libtool –mode=install /usr/bin/install -c TangoTest '/usr/local/bin'
libtool: install: /usr/bin/install -c .libs/TangoTest /usr/local/bin/TangoTest
/bin/mkdir -p '/usr/local/include/tango'
/usr/bin/install -c -m 644 TangoTestClass.h TangoTest.h '/usr/local/include/tango'
make[3]: Leaving directory '/opt/software/tango-9.2.5a/cppserver/tangotest'
make[2]: Leaving directory '/opt/software/tango-9.2.5a/cppserver/tangotest'
Making install in database
make[2]: Entering directory '/opt/software/tango-9.2.5a/cppserver/database'
CXXLD DataBaseds
/usr/bin/ld: /usr/lib/libomniDynamic4.a(any.o): relocation R_X86_64_32 against `.rodata.str1.8' can not be used when making a shared object; recompile with -fPIC
/usr/lib/libomniDynamic4.a: error adding symbols: Bad value
collect2: error: ld returned 1 exit status
Makefile:507: recipe for target 'DataBaseds' failed
make[2]: *** [DataBaseds] Error 1
make[2]: Leaving directory '/opt/software/tango-9.2.5a/cppserver/database'
Makefile:374: recipe for target 'install-recursive' failed
make[1]: *** [install-recursive] Error 1
make[1]: Leaving directory '/opt/software/tango-9.2.5a/cppserver'
Makefile:457: recipe for target 'install-recursive' failed
make: *** [install-recursive] Error 1

We refereed almost all the related posts on forum.
Tried the following solution also:
goetz@pcandy:~/tango/tango-9.2.2$ diff configure configure.orig
< MYSQLCLIENT_LIBS="-lmysqlclient"

> MYSQLCLIENT_LIBS="-lmysqlclient_r"

Refereed following related posts:

However we could not succeed.. Are we missing something?
Any help would be appreciated

Thanks and Regards,


How did you install omniORB? Where did you install it?
It looks like you have a file named libomniDynamic4.a in /usr/lib directory.
Do you have a file named Where is it installed?
I might be wrong but It looks like your compiler is not finding the file.

Hoping this help…
Rosenberg's Law: Software is easy to make, except when you want it to do something new.
Corollary: The only software that's worth making is software that does something new.
Register or login to create to post a reply.