omniORB 4.3 is not yet supported by Tango and it will probably not be supported on cppTango 9.3.
See for instance https://gitlab.com/tango-controls/cppTango/-/issues/760

You'll probably have to wait for cppTango 9.4 (9.4.0 should be released on 2nd October 2022. Not sure that omniORB 4.3 will be already supported).

Could you install omniORB4.2.x on your system instead?

You might be able to use –omni option (with 2 dashes) when running configure to specify a non-standard omniORB install location.

The following environment variables might be useful too.

omniORB4_CFLAGS
C compiler flags for omniORB4, overriding pkg-config
omniORB4_LIBS
linker flags for omniORB4, overriding pkg-config
omniCOS4_CFLAGS
C compiler flags for omniCOS4, overriding pkg-config
omniCOS4_LIBS
linker flags for omniCOS4, overriding pkg-config


You can get all these options and environment variables by running configure –help (2 dashes here).

I'm not 100% sure that it will bypass the omniORB 4.3 version installed on your system but it might be worth a try.
Rosenberg's Law: Software is easy to make, except when you want it to do something new.
Corollary: The only software that's worth making is software that does something new.
Edited 4 weeks ago