redpitaya device server

FYI : first DS for redpitaya

redpitaya is an opensource oscilloscope based on xilinx zynq SoC (redpitaya.com)

I have written a simple Tango device class (toggling leds for now, measure should be easy because there is C code source).

in order to not reinvent the wheel, I would like to check if there is already an other DS publicly available in the community ?


thanks
RedPitayaDS

- toggle leds
- channel 0 & 1 acquisition

Screen Shot 2015-07-08 at 11.59.18.png

Edited 6 years ago
Cool! Could this be used as a datalogger?

Edited 6 years ago

Cool! Could this be used as a datalogger?

of course … it could be a project for an intern of my classes if you have an open position

BTW, how did you put the image in the message ?
Use the Add attachments option at the BOTTOM of the submit window and click on the icon on the far right of the attachment to have it displayed in-line!
Hi Raphael,

Where we can find source code of your Tango device class for Red Pitaya?
One of our student intern at Solaris developed basic device server for Red Pitaya:
https://github.com/daneos/Tango-RedPitaya
http://repositories.daneos.com/solaris/download/Tango-RedPitaya_EN.pdf

Best regards,
Lukasz
Kind Regards,
Lukasz Zytniak

Control Software Engineer
—————————————————————
sorry,
I do not have access to my desktop now, but my DS is very simple :
it uses the redpitaya's acquire function to fetch the data :
https://github.com/RedPitaya/RedPitaya/tree/master/Test/acquire

what I have done is essentially a port of tango (and omniorb, zmq) to zynq (arm) SoC with openembedded. This is a different approach than yours, in the way it does not require an other host processor. My DeviceServer runs on redpitaya's zynq.

full paper here
regards
Edited 5 years ago
Hi,

I'm trying to install tango control on my redpitaya, but didn't succeed.
Without any problem I installed cmake-3.20, omniORB-4.2.3, libzmq-master and cppzmq-master.

After this I tried to compile tango control with
./configure –disabel-java –disable-dbserver (I just need the library for pytango)
and make

and then the script runs to

templ_inst

during compiling this file
my redpitaya reboots.

Can someone tell me how to solve this problem?
Or does anyone have an image with pytango for me.
The above links no longer work.

Best regards,
Johan
I have done this a long time ago using cross compilation: try petalinux or poky…

some info for the zedboard support are available here
Problem solved, it was a memory issue.
After creating a swapfile of 2GB and login via the serial COM port I was enable to create the pytango package.
 
Register or login to create to post a reply.