Polling of commands in PyTango

Hi Tango Community,

I use POGO to generate pythonHL source code for a device server.
When I enable polling for a command, it is set correctly. The line "polling_period=1000" is placed correctly in the source code and restarting the device server enables polling, everything is OK. However, when I change the polling period or disable polling altogether in POGO, generate the source code again and restart the device server, the polling behaviour of the device server does not change. The python source code is changed correctly. In Jive I can see that the polling settings are unchanged, which is why the polling behaviour is not changed. Changing the settings in Jive by hand resolves the issue.

So I think a change in the python source code does not change the polling settings in the database. Is this intentional or am I doing something wrong? Changing the setting for every device and every command is a workaround but unpractical.

Hi Dominik

Yes, it is confusing! You aren't doing anything wrong.

There was a recent PyTango issue asking the same. Please refer to it for a detailed explanation. Basically, the setting from the code is only used if there is no polling configured in the database already. The practical way of configuring this in a large system is with other tools.


Register or login to create to post a reply.