Installing jive on Debian Stretch

Reynald,

you are absolutely right. I could reproduce the problem on Ubuntu 18.04 with java 10.0.1 (the latest default java jdk in Ubuntu 18.04).

I followed the recipe you pointed out on stack overflow. It almost worked - I had to download the jacorb-omgapi-3.4.jar and add org.omg.Timebase to the list of exports. I modified the jive script as follows and then jive worked (and atk):

usr/bin/java –add-modules "java.corba"  –patch-module "java.corba=/home/goetz/tango/jacorb-omgapi-3.4.jar" –add-exports=java.corba/org.omg.CONV_FRAME=ALL-UNNAMED –add-exports=java.corba/org.omg.CORBA_2_5=ALL-UNNAMED –add-exports=java.corba/org.omg.PortableGroup=ALL-UNNAMED –add-exports=java.corba/org.omg.ETF=ALL-UNNAMED –add-exports=java.corba/org.omg.GIOP=ALL-UNNAMED –add-exports=java.corba/org.omg.SSLIOP=ALL-UNNAMED –add-exports=java.corba/org.omg.CSIIOP=ALL-UNNAMED –add-exports=java.corba/org.omg.TimeBase=ALL-UNNAMED -mx128m -DTANGO_HOST=$TANGO_HOST $applet_name $@

I will add something to the documentation so others do not fall into this trap. Maybe we could include this in the official scripts in the future.

Daniel can you try this to see if it works for you?

Andy
I have created a docker image of the latest version of Jive (7.19) which includes openjdk:8: https://hub.docker.com/r/andygotz/tango-jive/

You can try it out on any Linux system where docker is installed with:

docker pull andygotz/tango-jive:7.19
docker run -ti –rm -e DISPLAY=$DISPLAY -e TANGO_HOST=$TANGO_HOST -v /tmp/.X11-unix:/tmp/.X11-unix –net=host andygotz/tango-jive:7.19

It avoids the issue with the Java version by including openjdk:8. Should work on any system where docker works …

Andy

p.s. this uses the X11 DISPLAY of your Linux desktop. To make it work on WIndows you need to run a X11 server on your Windows desktop e.g. Xming.
Edited 4 months ago
Hej guys,

Indeed I can run jive and all the other libtango-java apps with openjdk-8 and version 11 did not work.
For now I am working with v. 8 because I have a similar issue with an EPICS Java app.

Thanks so much

Daniel
Hello, I just started a discussion on the debian-java[1] mailing list in order to be sure that CORBA will be usable on Debian based systems.

They proposed to package[2]. Do you know if the tango java part could work with it ?

Cheers

[1] https://lists.debian.org/debian-java/2018/07/msg00060.html
[2] https://github.com/javaee/glassfish-corba
Edited 3 months ago
@picca,

The package[2] seems like an interesting alternative to OpenJDK and Jacorb. It would be a nice exercise to try it. Hopefully I will find some time for that this Autumn.

Cheers,
 
Register or login to create to post a reply.