Standard Java packages questions

Hello.

Recently I've updated Java packages on my VM to the latest versions from Maven.

Here is the list of packages:
Astor-7.0.9.jar
ATKCore-9.3.1.jar
ATKPanel-5.8.jar
AtkTuning-2.8.jar
ATKWidget-9.3.1.jar
DBBench-1.3.jar
DeviceTree-1.9.6.jar
HDB++-1.10.jar
hdbpp-configurator-3.11.jar
jcalendar-1.4.jar
jhdbviewer-1.14.jar
Jive-7.21.jar
JSSHTerminal-1.10.jar
JTango-9.3.6-shaded.jar
jython-standalone-2.7.0.jar
log4j-1.2.15.jar
LogViewer-2.0.4.jar
Pogo-9.6.18.jar
tool_panels-3.2.jar


I'm not really familiar with Java, so I have some questions about it.

1) When I launch Jive or Astor, I receive the message like this:
SLF4J: Class path contains multiple SLF4J bindings.
SLF4J: Found binding in [jar:file:/usr/local/share/java/JTango-9.3.6-shaded.jar!/org/slf4j/impl/StaticLoggerBinder.class]
SLF4J: Found binding in [jar:file:/usr/local/share/java/ATKWidget-9.3.1.jar!/org/slf4j/impl/StaticLoggerBinder.class]
SLF4J: See http://www.slf4j.org/codes.html#multiple_bindings for an explanation.
SLF4J: Actual binding is of type [ch.qos.logback.classic.util.ContextSelectorStaticBinder]
Is this a critical situation and can I fix it?

2) Also I've started to receive debug messages when I open jhdbviewer.
SLF4J: The requested version 1.7.16 by your slf4j binding is not compatible with [1.6]
SLF4J: See http://www.slf4j.org/codes.html#version_mismatch for further details.
10:17:37.089 [main] DEBUG org.jacorb.config - no properties found for configuration jacorb
10:17:37.093 [main] DEBUG org.jacorb.orb.singleton - Set default native char codeset to UTF8
10:17:37.095 [main] DEBUG org.jacorb.orb.singleton - BufferManagerFactory: org.jacorb.orb.DefaultBufferManagerFactory@51cdd8a
10:17:37.095 [main] DEBUG org.jacorb.orb.singleton - BufferManager: org.jacorb.orb.BufferManager@d44fc21
..
I suppose it's related to the previous problem. Is it possible to turn the logging off?

3) When I try to "add" attribute in the Jhdbviewer to view its data, I receive exception

Exception in thread "AWT-EventQueue-0" java.lang.NoSuchMethodError: org.tango.jhdb.HdbReader.getSigInfo(Ljava/lang/String;I)Lorg/tango/jhdb/HdbSigInfo;
at HDBViewer.HDBTreePanel.attributeAction(HDBTreePanel.java:151)
at HDBViewer.AttributeTree.TreePanel.fireTreeListener(TreePanel.java:411)
at HDBViewer.AttributeTree.TreePanel.access$000(TreePanel.java:234)
..
at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

It also happen when I try to get data from my HDB using application from TangoVM, so I'm not sure if it's related to the Java package or to the system settings.

My VM is Debian 9.7, Tango 9.2.5a, MariaDB 10.3.12.
Hi,

If I were you, I would create this post in the Java section of the forum:
http://www.tango-controls.org/community/forum/c/development/java/

You would get more chances to get answers for these specific questions which are really Java related.
Many developers have subscribed to only specific sections of the forum.

Event though I think everybody should be interested in this section (General/Other), because there might be interesting topics here for everyone but well, this is only my opinion.

Cheers,
Reynald
Rosenberg's Law: Software is easy to make, except when you want it to do something new.
Corollary: The only software that's worth making is software that does something new.
 
Register or login to create to post a reply.